Feature | Programs | Support | Training | Development | Downloads | Free Tools | Newsletter | Links | About Us

Help on Installing Labbie,
your Data Retriever for the Civil Engineering Laboratory

If you don't know what Labbie is, click here to go to the Labbie Home Page.


Troubleshooting: Are You Having Difficulty Installing Labbie?

Labbie is intended for modern versions of Windows with the complete operating system and a recent version of Internet Explorer (5.1 or later).  A few problems may arise if your Windows is not up to date.  Here are some problems and their solutions.  If your problem is not listed, please e-mail us.

Windows Installer 3.1 is Needed
Internet Explorer 5.01 or Greater is Needed
".NET Framework 2.0" is Needed
ReportViewer is Needed
Crystal Decisions is Needed
ADODB is Needed
Missing "Primary Interop Assemblies"

Note: If Labbie does not install and the cause is not obvious, the Setup form will usually give you a Details button.  Click it to get the location of the Setup Log File.  Open the file and see what the error is.  If you can't work it out, e-mail it to us.  Here are some:

The remote server returned an error: (407) Proxy Authentication Required
If All Else Fails...


Windows Installer 3.1 is Needed

Unless your system is damaged or quite old, you should already have Windows Installer 3.1.  However, if you get a message that you need it, download it by clicking here.  Then run* (Open) the downloaded file to install it.

Internet Explorer 5.01 or Greater is Needed

Prerequisite check for system component .NET Framework 2.0 fails with the following error message:  "Installation of the .NET Framework 2.0 requires Internet Explorer 5.01 or greater. Contact your application vendor."

This may happen on versions of Windows prior to XP.  Solution: Download and install Internet Explorer 6 SP1 from microsoft.com.

".NET Framework 2.0" is Needed

Labbie can run on earlier versions of Windows, but you will have to install "dot NET Framework version 2.0" first if it is not already installed on your PC.  It should download and install automatically (if required) when you click the Install button on the Labbie Setup page, but if this does not happen for any reason, click here to go to the download page for the .NET Framework (22 MB).

ReportViewer is Needed

Message: System Update Required:
Unable to install or run the application. The application requires that assembly Microsoft.ReportViewer.ProcessingObjectModel Version 8.0.0.0 be installed in the Global Assembly Cache (GAC) first.


To fix this problem, download ReportViewer.exe (1.9 MB) to a suitable folder such as C:\Temp and then run* it.

Crystal Decisions is Needed

Message: System Update Required:
Unable to install or run the application. The application requires that assembly Crystal Decisions Version 10.2.3600.0 be installed in the Global Assembly Cache (GAC) first.

To fix this problem, download CRRedist2005_x86.msi (17 MB) from our web site to a suitable folder such as C:\Temp  Set the download window to NOT close when download completes.  When download is complete, click the button to open the file, and follow installation instructions (alternatively, run* it later).

ADODB is Needed

Message: System Update Required:
Unable to install or run the application. The application requires that assembly ADODB Version 7.0.3300.0 be installed in the Global Assembly Cache (GAC) first.


To fix this problem, download FixADODB.exe (100KB) to C:\Temp and then run* it.  When you run it, click UnZip to copy the missing  ADODB.DLL to the folder "C:\Windows\Assembly".
If your Windows won't let you unzip to "C:\Windows\Assembly", Unzip instead to C:\Temp, then find and run the file C:\Temp\CopyADODB.bat

Missing "Primary Interop Assemblies"

Solution: Download FixInterop.exe (1.8 MB) to a suitable folder such as C:\Temp and then run* it.  When you run it, click Unzip to place the missing DLL files on the folder "C:\Program Files\Microsoft.NET\Primary Interop Assemblies".  Do not overwrite existing files.

**Note: To Run a program or Open a file, find "Windows Explorer" or "My Computer" on the desktop and double-click it (or press "Windows key" (ÿ) + E on the keyboard), find the file and double-click it.  Alternatively, use a file, click Start > Run (> Browse)).

The remote server returned an error: (407) Proxy Authentication Required

This is a known Microsoft Error in .NET Framework 2.0:  It occurs on trying to install a ClickOnce application when a client computer is configured to use a proxy server that requires authentication.

Go here http://support.microsoft.com/kb/917952 to see more details and find a link to download the KB917952 Hotfix.  Run the downloaded HotFix to install it.


I am about to give up on installing Labbie: What must I do?

All is not lost.  If you definitely want to buy Labbie and can't get it installed, we can send a specialist to do the installation or do it remotely via the internet.  If you aren't sure and want to try it out, we are in the process of developing a simpler, Microsoft Access-based version, "Labbie A".  It is easier to install and has much of the functionality of the full Labbie, but does not support SQL Server.  e-mail us here.

Back to top | Latest Versions | Troubleshoot Setup | Programs from Software Africa | Software Africa Home


Press Ctrl+F to search this page for keywords.


| Back to top | ©2013 Communication in Action cc t/a Software Africa. All rights reserved.  Updated 19 June 2013 e-mail Webmaster.